Protocole de transport en temps réel RTP TEL502
Enseignant:
Email:
Durée totale du cours: 22.5 H
Semestre : 5
Option Ingénierie systèmes et réseaux
Nombre de crédits : 2
| Modules
spécialisés |
Modules de
base |
Sciences et techniques de
l’ingénierie |
Préparation à la carrière professionnelle |
|
|
X |
|
| Nombre d’heures |
Activités hors classe |
| 22.5 |
18 |
Protocole de contrôle RTP (RTP/RTCP)
Code : TEL502 Protocole de transport en temps réel (RTP)
Sommaire :
Un protocole conçu pour gérer le trafic en temps réel (comme l’audio et la vidéo) d’Internet est connu sous le nom de
protocole de transport en temps réel (RTP).
RTP doit être utilisé avec UDP . Il ne dispose d’aucun mécanisme de livraison comme la multidiffusion ou les numéros de port. RTP prend en charge différents formats de fichiers tels que MPEG et MJPEG. Il est très sensible aux retards de paquets et moins sensible à la perte de paquets.
Ce protocole est développé par Internet Engineering Task Force (IETF) de quatre membres :
- Casner (conception de paquets)
- Jacobson (conception de paquets)
- Schulzrinne (Université Columbia)
- Frederick (Blue Coat Systems Inc.)
Le protocole RTP est publié pour la première fois en 1996 et connu sous le nom de
RFC 1889 . En suite il a été publié en 2003 avec le nom de
RFC 3550 .
Applications du RTP :
- RTP aide principalement au mixage, au séquençage et à l’horodatage des médias.
- Voix sur protocole Internet (VoIP)
- Téléconférence vidéo sur Internet.
- Diffusion audio et vidéo sur Interne
Documents normatifs
- RFC 3550, Standard 64, RTP : un protocole de transport pour les applications en temps réel
- RFC 3551, Standard 65, Profil RTP pour les conférences audio et vidéo avec un contrôle minimal
- RFC 4855, Enregistrement du type de média des formats de charge utile RTP
- RFC 4856, Enregistrement du type de média des formats de charge utile dans le profil RTP pour les conférences audio et vidéo
- RFC 7656, Une taxonomie de la sémantique et des mécanismes pour les sources de protocole de transport en temps réel (RTP)
- RFC 3190, format de charge utile RTP pour audio DAT 12 bits et audio échantillonné linéaire 20 et 24 bits
- RFC 6184, format de charge utile RTP pour la vidéo H.264
- RFC 3640, Format de charge utile RTP pour le transport de flux élémentaires MPEG-4
- RFC 6416, format de charge utile RTP pour les flux audio/visuels MPEG-4
- RFC 2250, format de charge utile RTP pour vidéo MPEG1/MPEG2
- RFC 4175, format de charge utile RTP pour la vidéo non compressée
- RFC 6295, format de charge utile RTP pour MIDI
- RFC 4696, Guide d’implémentation pour RTP MIDI
- RFC 7587, format de charge utile RTP pour le codec vocal et audio Opus
- RFC 7798, format de charge utile RTP pour le codage vidéo à haute efficacité (HEVC)
Aperçu du programme
La formation RTP/RTCP permet de bien comprendre la signalisation RTP/RTCP, le format des messages et les protocoles.
Ce cours est développé en utilisant les dernières techniques d’apprentissage et de livraison qui offrent des opportunités de développement inégalées.
Contenu
Plan
- Introduction
- Communication en temps réel
- RTP
- Limitation de débit RTCP
- RTP et le temps réel
- Caractéristiques
- Horodatage des données
- Synchronisation des flux
- Résistance contre les pertes, etc.
- Identification des participants
- Surveillance de l’état de la connexion
- Contrôle de flux
- Contrôle de congestion
- Transcodage
Applications typiques
- Voix sur IP (« VoIP »)
- Visioconférence
- Vidéo
- Jeux interactives
- Mises à jour de mouvement ■
- Communication entre participants
Applications moins typiques
- Diffusion d’actualités
- Données (par exemple à propos de la bourse)
- Moniteur à distance
- Control télémétrique
- RTP à été conçu plutôt pour audio et vidéo
Prérequis
Bien que ce cours ne nécessite aucune connaissance ou compréhension préalable de RTP/RTCP, une compréhension de base de la technologie VOIP et IP serait bénéfique
Méthodes d’enseignement et d’apprentissage
- Enseignement frontal (magistral) avec des exemples à résoudre en
- Exercices théoriques et études de cas (présentation et discussion).
- Travaux à faire à domicile (mini-projet, exposé, compte-rendu, …)
Connaissances et compétences pré-requises
- Réseaux et technologies d’accès
- Technologie IP
Prérequis spécifiques
Communications informatiques et de données ou connaissances équivalentes
Références bibliographiques
- Un polycopié (Notes du cours) de l’enseignant sera
- IP Communications and Services for NGN, Johnson I. AgbInyA, Wiley, Edition,
- Henry Sinnreich et Alan B. Johnston, Internet Communications Using SIP: Delivering VoIP and Multimedia Services with Session Initiation Protocol, 2e édition, Wiley, août 2006, ISBN : 0-471-77657-2
Modalité d’évaluation
- 40% Contrôle continu (Test + Travail individuel avec présentation orale, Devoir surveillé, …)
- 60% Examen semestriel
Résultats d’apprentissage :
À l’issue de ce cours, les participants auront une bonne compréhension de:
- Présentation de la propriété intellectuelle
- Vue d’ensemble et fonctions de RTP/RTCP
- Types de paquets RTP/RTCP
- Format et champs des paquets RTP/RTCP
- Scénarios d’utilisation RTP/RTCP
[lifterlms_course_continue_button]